AM2 and MythTV war stories, a continuing saga

by Nicholas Petreley

Warning to Linux users who want to upgrade to socket AM2 motherboards: You will almost definitely run into problems with Linux. I have an ASUS M2N32-SLI Deluxe motherboard. I upgraded the BIOS to the latest version, and that broke IO-APIC on all versions of the Linux kernel I've tried, including 2.6.17.7. I couldn't boot Linux without the "noapic" boot parameter. I solved this problem by restoring an older BIOS, and I lost a fancy NVidia acceleration feature in the process. That's no big deal for me because the feature primarily benefits Windows games and I don't play Windows games often enough to care.

I'd still like to see this problem solved, and I don't see a solution coming anytime soon. Based on what I've read in the Linux kernel developer mailing list, few people have AM2-based boards and little if any work is being done to deal with them. Thanks to a spinal problem, I'm in too much pain to mess with BIOS versions and debugging APIC problems, so the kernel developers can't get help from me. In fact, typing this is an exercise in masochism. But I'm hoping someone out there will get an ASUS M2N32-SLI Deluxe motherboard and help out.

MythTV becomes reality

You may recall from a previous blog entry that I've been putting together a MythTV box. I ran into numerous problems based on the fact that no capture cards exist to capture the output of my cable box. In case you don't remember the details, my Scientific Atlanta Explorer 8000HD shuts off the AVI, S-Video and cable outputs when you put the box in HDTV mode.

I tried a HD5500 pcHDTV card from pcHDTV, which captures digital cable signals. There are two problems with this card. First, you guessed it, it has problems with my socket-AM2 board. Linux locks up frequently when I have this card installed. That, alone, wouldn't be a big issue because I only installed it in the AM2 box to experiment with it. The MythTV box uses a much older motherboard.

The real problem is that this card only captures the very few digital channels that are unencrypted. That makes it pretty much useless for my MythTV box. I should have known this would be the case before I bought the card, but my unrealistic optimism drove my decision to try it.

Disaster strikes gold

As if I didn't have enough problems, my Explorer 8000HD cable box died. I visited my nearest Time Warner office to replace it when I noticed that they carry a newer model called the Scientific Atlanta Explorer 8300HD. I asked for the new model, and they had one available.

Now I'm thrilled that my 8000HD died, because this new cable box solves all my problems. It continues to output a standard definition signal from the cable out, and I'm assuming also from the S-Video and AVI connections, even when this box is in HDTV mode. All I have to do is hook up the output of this box to my Hauppauge PVR500 card, and I should be in business. I haven't done it yet (see pinched nerve, spinal problem), but I expect it to work fine.

I even have an IR receiver and an IR blaster which I'm hoping I can configure to have my MythTV box change channels on the cable box. This way, my MythTV box will get every channel the cable box can receive. I can use MythTV to schedule recordings and trust it to change the channel on the cable box when the program airs.

I'm assuming that the HDTV channels will be sent to the MythTV box in standard definition (rather than not being sent at all), but that doesn't bother me.

If all goes well, I should have the ultimate MythTV box up and running once I get my pain under control. I'll keep you posted, and eventually write up all the details in Linux Journal for the benefit of others who want to accomplish the same goal.

If you want to get a jump on me, and you're interested in building your MythTV box based on Ubuntu 6.06 Dapper Drake (which is what I have installed), I strongly recommend that you download the MythTV sources and compile them yourself. You can get Ubuntu-based MythTV using apt-get or any of the installers on Ubuntu, but it's an older version that doesn't work nearly as well.

That's it for now. To be continued...