ssh tunnel to http which redirects to https failure

Gidday LJ and LJ fans,

I'm a long time dabbler in the 'nix black arts but only recently got serious about it.

I run tomcat at home for, amongst other things, my wiki. I set it up with fairly serious security to require users to login, and it also forces redirection to https for all read/write.

I've just setup a ssh tunnel so I can access it (thank to Linux Journal's help).

ssh -T -N -L 3210:localhost:8080 oehmsmith@xx.xx.65.14 -oPort=13213

So this ssh' to port 13213 on my server and it redirects to port 8080. That's how i understand it and that part seems to work.

The tomcat and its included examples, documentation and other webapps come up fine. But when I hit my wiki the security redirects to:

http://kanga.local:8080/JSPWiki/Wiki.jsp?page=MyDayAtWork

(Mmmm, I'm not sure why it isn't https://kanga.local:8443. But that is not an issue at the moment).

And kanga.local is of course local to my home network.

I tried setting the tunnel directly to :8443 (https) but when I go to access Tomcat what's returned is a binary (encrypted) file.

As I'm new to this I'm hoping somebody more wise than I in this area can tell me what I can do to get around this (apart from killing the security policy I've setup on my wiki).

Feedback appreciated!

Cheers,

Brooke

Free Dummies Books
Continuous Engineering

Learn:

  • What continuous engineering is
  • How to continuously improve complex product designs
  • How to anticipate and respond to markets and clients
  • How to get the most out of your engineering resources

Get your free book now

Sponsored by IBM

Free Dummies Books
Service Virtualization

Learn to:

  • Define service virtualization
  • Select the most beneficial services to virtualize
  • Improve your traditional approach to testing
  • Deliver higher-quality software faster

Get your free book now

Sponsored by IBM